Google Earth 6 adres arama sorunu

____________________________________________________________________

Linux üzerinde Google Earth 6 ile bir konum ararken adresi yazıp aramayı başlattıktan sonra “Geçersiz HTTP isteği!!!” hatası alıyorsanız sebebi libcurl.so.4 kütüphane dosyasının eski olmasıdır. Çaresi var. Hemen uçbirimden ya da işte terminale girip işletim sisteminize göre aşağıdaki komutu yazarak dosya yöneticinizde tam yetkiye erişebilirsiniz:

için: “sudo nautilus

Kubuntu için: “sudo dolphin

Bu komutları yazıp Enter tuşuna basın ve root şifrenizi de girip süper kullanıcı yetkilerinizi donanmış halde dosya gezginini açın. Bundan sonra da Bilgisayar sekmesine ya da “/” yani ana dizininize tıklayıp oradan şu yolu takip edin:

/opt/google/earth/free

Burada libcurl.so.4 dosyasını bulup bu dosyayı bu konumdan uzaklaştırdığınızda arama komutları tekrar çalışacaktır.

Yeni bir çözüm ise paket yöneticisinden libcurl3 paketini yükleyip /usr/lib/i386-linux-gnu/ yolundaki libcurl.so.4 ve libcurl.so.4.3.0 dosyalarını /opt/google/earth/free/ klasörü içine kopyalamak. Bu şekilde de güncel libcurl kütüphaneniz güncel bir halde kullanabilirsiniz.

Ayrıca Google Earth 7 ile ilgili Panoramio fotoğraflarının görüntülenememesi sorunu da var. Bunun nedeni de QT kütüphaneleri ile ilgili bir mesele, kodlar ile kütüphane arasında biraz uyumsuzluk var. libQtWebKit.so.4 dosyasının daha yeni bir sürümünü yüklemeyi denedim. Eski dosya 16 MB kadar, yeni dosya ise 27 MB. Bundan sonra Panoramio kutucuğu açılıyor ve resim yükleniyor, resim görüntülendikten bir saniye geçmeden de Google Earth çöküyor. Farklı kütüphane dosyaları ile vs. denedim yazılımı ama şu an için daha ileri gidemedim. Görüntüyü ancak bir saniyeye yakın bir süre göstertebiliyorum, sonra da çöküş… 🙂